using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\p{L}\s]*\p{L})\p{L}*";
string substitution = @"$1";
string input = @"Aliquam ipsum ex, tempus ornare semper ac, varius vitae nibh.
Dumnezeu a zis: „Să fie o întindere între ape, și ea să despartă apele de ape";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}