use strict;
my $str = 'Aliquam ipsum ex, tempus ornare semper ac, varius vitae nibh.
Dumnezeu a zis: „Să fie o întindere între ape, și ea să despartă apele de ape';
my $regex = qr/([^\p{L}\s]*\p{L})\p{L}*/up;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";