re = /([^\p{L}\s]*\p{L})\p{L}*/
str = 'Aliquam ipsum ex, tempus ornare semper ac, varius vitae nibh.
Dumnezeu a zis: „Să fie o întindere între ape, și ea să despartă apele de ape'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result