package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\p{L}\s]*\p{L})\p{L}*`)
var str = `Aliquam ipsum ex, tempus ornare semper ac, varius vitae nibh.
Dumnezeu a zis: „Să fie o întindere între ape, și ea să despartă apele de ape`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}