$re = '/([^\p{L}\s]*\p{L})\p{L}*/u';
$str = 'Aliquam ipsum ex, tempus ornare semper ac, varius vitae nibh.
Dumnezeu a zis: „Să fie o întindere între ape, și ea să despartă apele de ape';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;