# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!ajax)(?!index\.cfm)(.*?).cfm.*$/index.cfm?p=$1/gm;t' <<< "contact.cfm
contact.cfm?p=1
contact.cfm?p=cc.cfm
page.cfm
contact
index.cfm?p=contact
ajax/contact-form.cfm
index.cfm?p=contact.cfm
"