#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!ajax)(?!index\.cfm)(.*?).cfm.*$"
Local $sString = "contact.cfm" & @CRLF & _
"contact.cfm?p=1" & @CRLF & _
"contact.cfm?p=cc.cfm" & @CRLF & _
"page.cfm" & @CRLF & _
"" & @CRLF & _
"contact" & @CRLF & _
"index.cfm?p=contact" & @CRLF & _
"ajax/contact-form.cfm" & @CRLF & _
"index.cfm?p=contact.cfm" & @CRLF & _
""
Local $sSubst = "index.cfm?p=$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)