import Foundation
let pattern = #"^(?!ajax)(?!index\.cfm)(.*?).cfm.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
contact.cfm
contact.cfm?p=1
contact.cfm?p=cc.cfm
page.cfm
contact
index.cfm?p=contact
ajax/contact-form.cfm
index.cfm?p=contact.cfm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"index.cfm?p=$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)