using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!ajax)(?!index\.cfm)(.*?).cfm.*$";
string substitution = @"index.cfm?p=$1";
string input = @"contact.cfm
contact.cfm?p=1
contact.cfm?p=cc.cfm
page.cfm
contact
index.cfm?p=contact
ajax/contact-form.cfm
index.cfm?p=contact.cfm
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}