import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!ajax)(?!index\\.cfm)(.*?).cfm.*$";
final String string = "contact.cfm\n"
+ "contact.cfm?p=1\n"
+ "contact.cfm?p=cc.cfm\n"
+ "page.cfm\n\n"
+ "contact\n"
+ "index.cfm?p=contact\n"
+ "ajax/contact-form.cfm\n"
+ "index.cfm?p=contact.cfm\n";
final String subst = "index.cfm?p=$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}