re = /^(?!ajax)(?!index\.cfm)(.*?).cfm.*$/m
str = 'contact.cfm
contact.cfm?p=1
contact.cfm?p=cc.cfm
page.cfm
contact
index.cfm?p=contact
ajax/contact-form.cfm
index.cfm?p=contact.cfm
'
subst = 'index.cfm?p=$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result