# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+ \w{3,}).*?(\d{1,2}\/\d{1,2}\/\d{2})/\1 \2/gm;t' <<< "John Smith has a birthday of 2/29/90"