using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+ \w{3,}).*?(\d{1,2}/\d{1,2}/\d{2})";
string substitution = @"\1 \2";
string input = @"John Smith has a birthday of 2/29/90";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}