import Foundation
let pattern = #"(\w+ \w{3,}).*?(\d{1,2}/\d{1,2}/\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"John Smith has a birthday of 2/29/90"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 \2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)