package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+ \w{3,}).*?(\d{1,2}/\d{1,2}/\d{2})`)
var str = `John Smith has a birthday of 2/29/90`
var substitution = "\1 \2"
fmt.Println(re.ReplaceAllString(str, substitution))
}