re = /(\w+ \w{3,}).*?(\d{1,2}\/\d{1,2}\/\d{2})/m
str = 'John Smith has a birthday of 2/29/90'
subst = '\\1 \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result