#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w+ \w{3,}).*?(\d{1,2}/\d{1,2}/\d{2})"
Local $sString = "John Smith has a birthday of 2/29/90"
Local $sSubst = "\1 \2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)