// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w+ \w{3,}).*?(\d{1,2}/\d{1,2}/\d{2})").unwrap();
let string = "John Smith has a birthday of 2/29/90";
let substitution = "\\1 \\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}