const regex = new RegExp('(\\w+ \\w{3,}).*?(\\d{1,2}/\\d{1,2}/\\d{2})', 'gm')
const str = `John Smith has a birthday of 2/29/90`;
const subst = `\1 \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);