use strict;
my $str = 'John Smith has a birthday of 2/29/90';
my $regex = qr/(\w+ \w{3,}).*?(\d{1,2}/\d{1,2}/\d{2})/mp;
my $subst = '\\1 \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";