import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\|\\s*([^=]*?)\\s*=(.*)$";
final String string = "{{Infobox XYZ\n"
+ "|first parameter=foo\n"
+ "|second_parameter= \n"
+ "|3rd parameter=bar\n"
+ "|4th=bazzzzz\n"
+ "|5th= \n"
+ "|etc.= \n"
+ "}}";
final String subst = " | $1 = $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}