import re
regex = re.compile(r"^\s*\|\s*([^=]*?)\s*=(.*)$", flags=re.MULTILINE)
test_str = ("{{Infobox XYZ\n"
"|first parameter=foo\n"
"|second_parameter= \n"
"|3rd parameter=bar\n"
"|4th=bazzzzz\n"
"|5th= \n"
"|etc.= \n"
"}}")
subst = " | $1 = $2"
result = regex.sub(subst, test_str)
if result:
print(result)