import Foundation
let pattern = #"^\s*\|\s*([^=]*?)\s*=(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{{Infobox XYZ
|first parameter=foo
|second_parameter=
|3rd parameter=bar
|4th=bazzzzz
|5th=
|etc.=
}}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" | $1 = $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)