$re = '/^\s*\|\s*([^=]*?)\s*=(.*)$/m';
$str = '{{Infobox XYZ
|first parameter=foo
|second_parameter=
|3rd parameter=bar
|4th=bazzzzz
|5th=
|etc.=
}}';
$subst = " | $1 = $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;