const regex = /^\s*\|\s*([^=]*?)\s*=(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*\\|\\s*([^=]*?)\\s*=(.*)$', 'gm')
const str = `{{Infobox XYZ
|first parameter=foo
|second_parameter=
|3rd parameter=bar
|4th=bazzzzz
|5th=
|etc.=
}}`;
const subst = ` | $1 = $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);