re = /^\s*\|\s*([^=]*?)\s*=(.*)$/m
str = '{{Infobox XYZ
|first parameter=foo
|second_parameter=
|3rd parameter=bar
|4th=bazzzzz
|5th=
|etc.=
}}'
subst = ' | $1 = $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result