use strict;
my $str = '{{Infobox XYZ
|first parameter=foo
|second_parameter=
|3rd parameter=bar
|4th=bazzzzz
|5th=
|etc.=
}}';
my $regex = qr/^\s*\|\s*([^=]*?)\s*=(.*)$/mp;
my $subst = ' | $1 = $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";