import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+)(' \\+[\\r\\n]{1,2} +')(.+)$";
final String string = " 'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I' +\n"
+ " 'D is null and v.Block<>1')";
final String subst = "\\1\\3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}