# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.+)(' \+[\r\n]{1,2} +')(.+)$"
test_str = (" 'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I' +\n"
" 'D is null and v.Block<>1')")
subst = "\\1\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.