re = /^(.+)(' \+[\r\n]{1,2} +')(.+)$/
str = ' \'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I\' +
\'D is null and v.Block<>1\')'
subst = '\\1\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result