const regex = /^(.+)(' \+[\r\n]{1,2} +')(.+)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+)(\' \\+[\\r\\n]{1,2} +\')(.+)$', 'g')
const str = ` 'where v.VagonID=:VagonID and v.Vypis_ID is null and v.Nat_List_I' +
'D is null and v.Block<>1')`;
const subst = `\1\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);