# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\{\s\d(?:[\d]*\.\d+|[\d]*)\}/$0|/g;t' <<< "{ 16812},
{ 16812},
{ 16813},
{ 16819},
{ 16812},
{value 16812},
{value 16812]},"