using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\s\d(?:[\d]*\.\d+|[\d]*)\}";
string substitution = @"$0|";
string input = @"{ 16812},
{ 16812},
{ 16813},
{ 16819},
{ 16812},
{value 16812},
{value 16812]},";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}