import Foundation
let pattern = #"\{\s\d(?:[\d]*\.\d+|[\d]*)\}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{ 16812},
{ 16812},
{ 16813},
{ 16819},
{ 16812},
{value 16812},
{value 16812]},
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0|"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)