#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\{\s\d(?:[\d]*\.\d+|[\d]*)\}"
Local $sString = "{ 16812}," & @CRLF & _
"{ 16812}," & @CRLF & _
"{ 16813}," & @CRLF & _
"{ 16819}," & @CRLF & _
"{ 16812}," & @CRLF & _
"{value 16812}," & @CRLF & _
"{value 16812]},"
Local $sSubst = "$0|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)