$re = '/\{\s\d(?:[\d]*\.\d+|[\d]*)\}/';
$str = '{ 16812},
{ 16812},
{ 16813},
{ 16819},
{ 16812},
{value 16812},
{value 16812]},';
$subst = "$0|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;