re = /\{\s\d(?:[\d]*\.\d+|[\d]*)\}/
str = '{ 16812},
{ 16812},
{ 16813},
{ 16819},
{ 16812},
{value 16812},
{value 16812]},'
subst = '$0|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result