import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\s\\d(?:[\\d]*\\.\\d+|[\\d]*)\\}";
final String string = "{ 16812},\n"
+ "{ 16812},\n"
+ "{ 16813},\n"
+ "{ 16819},\n"
+ "{ 16812},\n"
+ "{value 16812},\n"
+ "{value 16812]},";
final String subst = "$0|";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}