use strict;
my $str = '{ 16812},
{ 16812},
{ 16813},
{ 16819},
{ 16812},
{value 16812},
{value 16812]},';
my $regex = qr/\{\s\d(?:[\d]*\.\d+|[\d]*)\}/p;
my $subst = '$0|';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";