package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{\s\d(?:[\d]*\.\d+|[\d]*)\}`)
var str = `{ 16812},
{ 16812},
{ 16813},
{ 16819},
{ 16812},
{value 16812},
{value 16812]},`
var substitution = "$0|"
fmt.Println(re.ReplaceAllString(str, substitution))
}