import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "mi nombre es (?<name>[\\w\\W]+?) y mi correo es (?<email>[\\w\\W]+?) y quiero un cupo";
final String string = "Hola, mi nombre es Carlos y mi correo es carlos@carlos.com y quiero un cupo\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}