// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"mi nombre es (?<name>[\w\W]+?) y mi correo es (?<email>[\w\W]+?) y quiero un cupo").unwrap();
let string = "Hola, mi nombre es Carlos y mi correo es carlos@carlos.com y quiero un cupo
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}