$re = '/mi nombre es (?<name>[\w\W]+?) y mi correo es (?<email>[\w\W]+?) y quiero un cupo/';
$str = 'Hola, mi nombre es Carlos y mi correo es carlos@carlos.com y quiero un cupo
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);