import re
regex = re.compile(r"mi nombre es (?<name>[\w\W]+?) y mi correo es (?<email>[\w\W]+?) y quiero un cupo")
test_str = ("Hola, mi nombre es Carlos y mi correo es carlos@carlos.com y quiero un cupo\n\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")