import Foundation
let pattern = #"mi nombre es (?<name>[\w\W]+?) y mi correo es (?<email>[\w\W]+?) y quiero un cupo"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Hola, mi nombre es Carlos y mi correo es carlos@carlos.com y quiero un cupo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}