re = /mi nombre es (?<name>[\w\W]+?) y mi correo es (?<email>[\w\W]+?) y quiero un cupo/
str = 'Hola, mi nombre es Carlos y mi correo es carlos@carlos.com y quiero un cupo
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end