#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)==(\w.*?)=="
Local $sString = "==this is a test==" & @CRLF & _
"" & @CRLF & _
"here ==is another test== and yet ==some other test=="
Local $sSubst = "==<mark>$1</mark>=="
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)