// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)==(\w.*?)==").unwrap();
let string = "==this is a test==
here ==is another test== and yet ==some other test==";
let substitution = "==<mark>$1</mark>==";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}