import re
regex = re.compile(r"==(\w.*?)==", flags=re.MULTILINE)
test_str = ("==this is a test==\n\n"
"here ==is another test== and yet ==some other test==")
subst = "==<mark>$1</mark>=="
result = regex.sub(subst, test_str)
if result:
print(result)