using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"==(\w.*?)==";
string substitution = @"==<mark>$1</mark>==";
string input = @"==this is a test==
here ==is another test== and yet ==some other test==";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}